<!DOCTYPE html>
<html lang="en">
<head>

<script type="text/javascript" src="https://ad.crwdcntrl.net/5/c=7268/pe=y/var=lotauds"></script>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="csrf-token" content="CUWzVJzTTRWZifdAPicTjdvzlYamP2Ev6PRTUt55">
<meta property="og:type" content="article" />
<link rel="amphtml" href="https://www.nst.com.my/amp/lifestyle/groove/2020/06/603350/showbiz-rock-band-queen-immortalised-british-postage-stamps">
<meta property="article:published_time" content="2020-06-25T13:00:20+08:00" />
<meta property="article:modified_time" content="2020-06-25T13:00:20+08:00" />
<meta property="article:author" content="Dennis Chua" />
<meta name="section" content="groove" />
<meta name="keywords" content="QUEEN, United Kingdom, stamps, Royal Mail, coronavirus, Covid-19" />
<meta name="numberOfWords" content="283" />
<title>#Showbiz: Rock band Queen immortalised on British postage stamps | New Straits Times</title>
<meta property="og:site_name" content="NST Online">
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@NST_Online" />
<meta name="twitter:title" content="#Showbiz: Rock band Queen immortalised on British postage stamps | New Straits Times" />
<meta name="description" content="KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.">
<meta name="og:description" content="KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.">
<meta property="og:url" content="https://www.nst.com.my/lifestyle/groove/2020/06/603350/showbiz-rock-band-queen-immortalised-british-postage-stamps">
<meta property="og:image" content="https://assets.nst.com.my/images/articles/dcqueenjun25_NSTfield_image_socialmedia.var_1593061214.jpg">
<meta property="twitter:image" content="https://assets.nst.com.my/images/articles/dcqueenjun25_NSTfield_image_socialmedia.var_1593061214.jpg">

<link href="https://fonts.googleapis.com/css?family=Montserrat:500,500i|Roboto:400,400i,500,500i,700,700i&display=swap" rel="stylesheet">
<link rel="shortcut icon" href="https://assets.nst.com.my/assets/favicon.ico?id=ad71dc20bc0c47a8454b" type="image/vnd.microsoft.icon" />
<link rel="stylesheet" href="https://assets.nst.com.my/assets/css/libraries.css?id=6a2781c12ab9e02d817c">
<link rel="stylesheet" href="https://assets.nst.com.my/assets/css/desktop/app.css?id=c64b3710fbe8e136546f">
<script type="text/javascript">
var dfpSection = 'groove';

var dfpPos = 'article';

var PWT={}; //Initialize Namespace
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
PWT.jsLoaded = function(){ //PubMatic pwt.js on load callback is used to load GPT
(function() {
var gads = document.createElement('script');
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
};
(function() {
var purl = window.location.href;
var url = '//ads.pubmatic.com/AdServer/js/pwt/121793/360';
var profileVersionId = '';
if(purl.indexOf('pwtv=')>0){
var regexp = /pwtv=(.*?)(&|$)/g;
var matches = regexp.exec(purl);
if(matches.length >= 2 && matches[1].length > 0){
profileVersionId = '/'+matches[1];
}
}
var wtads = document.createElement('script');
wtads.async = true;
wtads.type = 'text/javascript';
wtads.src = url+profileVersionId+'/pwt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(wtads, node);
})();
</script>
<script type="text/javascript">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</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-TF3NG6');</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1357345-6"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    
    gtag('config', 'UA-1357345-6', { 'optimize_id': 'GTM-5QH6S7J'});
    </script>
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "headline": "#Showbiz: Rock band Queen immortalised on British postage stamps",
    "image": ["https://assets.nst.com.my/images/articles/dcqueenjun25_NSTfield_image_listing_featured.var_1593061208.jpg"],
    "datePublished": "2020-06-25T13:00:20+08:00",
    "dateModified": "2020-06-25T13:00:20+08:00",
    "description": "KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.",
        "author": [
              {
          "@type": "Person",
          "name": "Dennis Chua"
        }          ],
        "mainEntityOfPage":{
      "@type":"WebPage",
      "@id":"https://www.nst.com.my/lifestyle/groove/2020/06/603350/showbiz-rock-band-queen-immortalised-british-postage-stamps"
    },
    "publisher": {
      "@type": "Organization",
      "name": "New Straits Times",
      "logo": {
        "@type": "ImageObject",
        "url": "https://assets.nst.com.my/sites/all/themes/custom/nst_v2/logo.png",
        "width": "703",
        "height": "64"
      }
    }
  }
</script>
</head>
<body>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TF3NG6"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="app" class="d-flex flex-column page-collection-lifestyle">
<header id="header" class="d-flex align-items-center container-fluid py-1 py-sm-3 px-4">
<div class="navbrand">
<a href="https://www.nst.com.my"><img src="https://assets.nst.com.my/assets/logo.png?id=7875aa246d12e700efcf" srcset="https://assets.nst.com.my/assets/logo.png?id=7875aa246d12e700efcf 1x, https://assets.nst.com.my/assets/logo@2x.png?id=5e8cc8502bdf1fc194f0 2x" class="d-block img-fluid mx-auto"></a>
</div>
<div class="header-content ml-auto text-right d-none d-sm-block pl-md-4 pl-lg-0">
<div class="current-date-time mb-2">
<span v-html="currentDateTime"></span>
</div>
<div class="social-media d-flex justify-content-end">
<a href="https://apps.apple.com/my/app/new-straits-times/id1033411389" target="_blank" class="mx-2"><img src="https://assets.nst.com.my/assets/social-appstore.png?id=55874db1b7dddd5f03a0" srcset="https://assets.nst.com.my/assets/social-appstore.png?id=55874db1b7dddd5f03a0 1x, https://assets.nst.com.my/assets/social-appstore@2x.png?id=21eb9bc11f7b62c78b53 2x" /></a>
<a href="https://play.google.com/store/apps/details?id=com.nstp.nst" target="_blank" class="mx-2"><img src="https://assets.nst.com.my/assets/social-playstore.png?id=4c620ae6fed478be37ec" srcset="https://assets.nst.com.my/assets/social-playstore.png?id=4c620ae6fed478be37ec 1x, https://assets.nst.com.my/assets/social-playstore@2x.png?id=f032d85f3abe4b8b7f3f 2x" /></a>
<a href="https://appgallery5.huawei.com/#/app/C101980395" target="_blank" class="mx-2"><img src="https://assets.nst.com.my/assets/social-appgallery.png?id=cda55ee066f90f5ddf80" srcset="https://assets.nst.com.my/assets/social-appgallery.png?id=cda55ee066f90f5ddf80 1x, https://assets.nst.com.my/assets/social-appgallery@2x.png?id=50d233f9f2497960e5d9 2x" /></a>
<a href="https://www.facebook.com/nstonline/" target="_blank" class="icon-facebook text-decoration-none mx-2"><i class="icofont-facebook"></i></a>
<a href="https://twitter.com/NST_Online" target="_blank" class="icon-twitter text-decoration-none mx-2"><i class="icofont-twitter"></i></a>
<a href="https://www.instagram.com/nstonline/?hl=en" target="_blank" class="icon-instagram text-decoration-none mx-2"><i class="icofont-instagram"></i></a>
<a href="https://www.youtube.com/channel/UCsWp7U58TZM8uOYtRrAqWhg" target="_blank" class="icon-youtube text-decoration-none mx-2"><i class="icofont-youtube-play"></i></a>
</div>
</div>
<div class="block-context ml-2">
<div class="block-content">
<picture><source media="(min-width: 768px)" srcset="https://assets.nst.com.my/assets/2020/nst-175.png"><source media="(max-width: 767px)" srcset="https://assets.nst.com.my/assets/2020/nst-175-mobile.png, https://assets.nst.com.my/assets/2020/nst-175-mobile@2x.png 2x"><img src="https://assets.nst.com.my/assets/2020/nst-175.png" class="img-responsive" style="max-height:70px; margin-top:5px;" /></source></source></picture>
</div>
</div>
</header>
<nav class="navbar navbar-expand-lg">
<navbar-toggler class="d-block d-lg-none align-self-center ml-2 ml-sm-0"></navbar-toggler>
<div class="collapse navbar-collapse order-3 order-lg-0" id="navbarToggler">
<ul class="navbar-nav mr-auto mt-2 mt-lg-0 py-2 px-4 p-sm-0">
<li class="nav-item">
<a class="nav-link mr-2" href="/news">News</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/business">Business</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2 active" href="/lifestyle">Life & Times</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/sports">Sports</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/world">World</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/videos">NST TV</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/opinion">Opinion</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/education">Education</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="https://vouchers.nst.com.my" target="_blank">Vouchers</a>
</li>
<li class="nav-item">
<a class="nav-link mr-2" href="/photos">Gallery</a>
</li>
</ul> </div>
<form class="form-inline my-0 px-2 px-sm-0 search-form" method="get" action="https://www.nst.com.my/search">
<input class="form-control mr-sm-2 form-search-text" type="search" placeholder="Search" aria-label="Search" name="keywords" value="">
<button class="btn my-2 my-sm-0" type="submit"><i class="icofont-search-1"></i></button>
</form>
</nav>
<div class="content-top">
<category-nav categories="{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;,&quot;topics&quot;:{&quot;\/lifestyle\/bots&quot;:{&quot;tid&quot;:22828,&quot;name&quot;:&quot;Bots&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/bots&quot;,&quot;weight&quot;:53,&quot;internal_url&quot;:&quot;\/lifestyle\/bots&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}},&quot;\/lifestyle\/heal&quot;:{&quot;tid&quot;:53,&quot;name&quot;:&quot;Heal&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/heal&quot;,&quot;weight&quot;:54,&quot;internal_url&quot;:&quot;\/lifestyle\/heal&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}},&quot;\/lifestyle\/flair&quot;:{&quot;tid&quot;:22942,&quot;name&quot;:&quot;Flair&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/flair&quot;,&quot;weight&quot;:55,&quot;internal_url&quot;:&quot;\/lifestyle\/flair&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}},&quot;\/lifestyle\/jom&quot;:{&quot;tid&quot;:50,&quot;name&quot;:&quot;Jom!&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/jom&quot;,&quot;weight&quot;:56,&quot;internal_url&quot;:&quot;\/lifestyle\/jom&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}},&quot;\/lifestyle\/groove&quot;:{&quot;tid&quot;:22831,&quot;name&quot;:&quot;Groove&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/groove&quot;,&quot;weight&quot;:58,&quot;internal_url&quot;:&quot;\/lifestyle\/groove&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}},&quot;\/lifestyle\/sunday-vibes&quot;:{&quot;tid&quot;:22834,&quot;name&quot;:&quot;Sunday Vibes&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/sunday-vibes&quot;,&quot;weight&quot;:59,&quot;internal_url&quot;:&quot;\/lifestyle\/sunday-vibes&quot;,&quot;parent&quot;:{&quot;tid&quot;:1043,&quot;name&quot;:&quot;Lifestyle&quot;,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle&quot;,&quot;internal_url&quot;:&quot;\/lifestyle&quot;}}}}" current-category="groove" collection="lifestyle"></category-nav>
</div>
<div class="bg-light text-center">

<div id='div-gpt-ad-1397706669649-0' class="ad-unit-billboard mx-auto"></div>
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1397706669649-0'); });</script>
</div>
<main id="main" role="main" class="flex-fill">
<div class="py-4 container px-1 px-sm-0">
<div class="row">
<div class="col">
<article-component :article="{&quot;nid&quot;:603350,&quot;title&quot;:&quot;#Showbiz: Rock band Queen immortalised on British postage stamps&quot;,&quot;created&quot;:1593061220,&quot;changed&quot;:1593061220,&quot;sponsored&quot;:0,&quot;highlighted&quot;:0,&quot;url&quot;:&quot;https:\/\/www.nst.com.my\/lifestyle\/groove\/2020\/06\/603350\/showbiz-rock-band-queen-immortalised-british-postage-stamps&quot;,&quot;internal_url&quot;:&quot;\/lifestyle\/groove\/2020\/06\/603350\/showbiz-rock-band-queen-immortalised-british-postage-stamps&quot;,&quot;field_article_author&quot;:{&quot;tid&quot;:834,&quot;name&quot;:&quot;Dennis Chua&quot;,&quot;email&quot;:null,&quot;photo&quot;:null,&quot;internal_url&quot;:&quot;\/authors\/dennis-chua&quot;},&quot;field_article_authors&quot;:[{&quot;tid&quot;:834,&quot;name&quot;:&quot;Dennis Chua&quot;,&quot;email&quot;:null,&quot;photo&quot;:null,&quot;internal_url&quot;:&quot;\/authors\/dennis-chua&quot;}],&quot;field_article_topic&quot;:{&quot;tid&quot;:22831,&quot;name&quot;:&quot;Groove&quot;},&quot;field_tags&quot;:[{&quot;tid&quot;:11873,&quot;name&quot;:&quot;QUEEN&quot;},{&quot;tid&quot;:16686,&quot;name&quot;:&quot;United Kingdom&quot;},{&quot;tid&quot;:12552,&quot;name&quot;:&quot;stamps&quot;},{&quot;tid&quot;:140157,&quot;name&quot;:&quot;Royal Mail&quot;},{&quot;tid&quot;:27214,&quot;name&quot;:&quot;coronavirus&quot;},{&quot;tid&quot;:152352,&quot;name&quot;:&quot;Covid-19&quot;}],&quot;field_article_images&quot;:[{&quot;fid&quot;:&quot;1913096&quot;,&quot;uid&quot;:&quot;9&quot;,&quot;filename&quot;:&quot;queen_3_1593061203.jpg&quot;,&quot;uri&quot;:&quot;gs:\/\/images\/articles\/queen_3_1593061203.jpg&quot;,&quot;filemime&quot;:&quot;image\/jpeg&quot;,&quot;filesize&quot;:&quot;145429&quot;,&quot;status&quot;:&quot;1&quot;,&quot;timestamp&quot;:&quot;1593061205&quot;,&quot;uuid&quot;:&quot;054a1281-5400-4a48-ba7a-18dfa320f8bb&quot;,&quot;rdf_mapping&quot;:[],&quot;alt&quot;:&quot;&quot;,&quot;title&quot;:&quot;&quot;,&quot;width&quot;:&quot;900&quot;,&quot;height&quot;:&quot;430&quot;,&quot;url&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/queen_3_1593061203.jpg&quot;,&quot;caption&quot;:&quot;(From left) May, Taylor, Mercury and Deacon of Queen&quot;,&quot;gn4id&quot;:&quot;nst-23114118&quot;}],&quot;field_article_images_filtered&quot;:[{&quot;fid&quot;:&quot;1913096&quot;,&quot;uid&quot;:&quot;9&quot;,&quot;filename&quot;:&quot;queen_3_1593061203.jpg&quot;,&quot;uri&quot;:&quot;gs:\/\/images\/articles\/queen_3_1593061203.jpg&quot;,&quot;filemime&quot;:&quot;image\/jpeg&quot;,&quot;filesize&quot;:&quot;145429&quot;,&quot;status&quot;:&quot;1&quot;,&quot;timestamp&quot;:&quot;1593061205&quot;,&quot;uuid&quot;:&quot;054a1281-5400-4a48-ba7a-18dfa320f8bb&quot;,&quot;rdf_mapping&quot;:[],&quot;alt&quot;:&quot;&quot;,&quot;title&quot;:&quot;&quot;,&quot;width&quot;:&quot;900&quot;,&quot;height&quot;:&quot;430&quot;,&quot;url&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/queen_3_1593061203.jpg&quot;,&quot;caption&quot;:&quot;(From left) May, Taylor, Mercury and Deacon of Queen&quot;,&quot;gn4id&quot;:&quot;nst-23114118&quot;}],&quot;field_article_videos&quot;:null,&quot;field_image_listing_featured_v2&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_listing_featured_v2.var_1593061216.jpg&quot;,&quot;field_image_listing_v2&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_listing_v2.var_1593061217.jpg&quot;,&quot;field_image_portrait&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_portrait.var_1593061218.jpg&quot;,&quot;field_image_featured_lifestyle&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_featured_lifestyle.var_1593061219.jpg&quot;,&quot;field_image_first_sb_featured&quot;:null,&quot;field_image_second_sb_featured&quot;:null,&quot;field_image_listing_featured&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_listing_featured.var_1593061208.jpg&quot;,&quot;field_image_listing_th&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_listing_th.var_1593061210.jpg&quot;,&quot;field_image_three_wide_col&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_three_wide_col.var_1593061211.jpg&quot;,&quot;field_image_two_wide_col&quot;:null,&quot;field_image_mobile_th&quot;:null,&quot;field_image_socialmedia&quot;:&quot;https:\/\/assets.nst.com.my\/images\/articles\/dcqueenjun25_NSTfield_image_socialmedia.var_1593061214.jpg&quot;,&quot;field_article_lead&quot;:&quot;KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.&quot;,&quot;body&quot;:&quot;&lt;p \/&gt;&lt;p&gt;KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.&lt;\/p&gt;&lt;p&gt;  American news portal UPI reported yesterday that Britain&#039;s Royal Mail unveiled a series of stamps on Tuesday featuring Queen&#039;s Brian May, Roger Taylor, the late Freddie Mercury and John Deacon. Mercury died at 45 in 1991.&lt;\/p&gt;&lt;p&gt;  \&quot;With their truly original, theatrical sound and effortless ability to mix musical styles, Queen is rock royalty. We pay tribute to one of the most loved bands of all time with these stunning stamps,\&quot; said Royal Mail&#039;s Philip Parker.&lt;\/p&gt;&lt;p&gt;  The Royal Mail will release the 13-stamp set on July 9, with pre-orders available beginning today.&lt;\/p&gt;&lt;p&gt;  The series features eight of Queen&#039;s album covers, including Queen II and News Of The World, a classic photo of the band and four shots from live shows.&lt;\/p&gt;&lt;p&gt;  \&quot;It&#039;s hard to put into words what I feel when looking at these beautiful stamps,\&quot; said Queen guitarist May.&lt;\/p&gt;&lt;p&gt;  \&quot;Since we four precocious boys started out on our quest 50 years ago, our lives have been devoted to making our impossible dream come true.&lt;\/p&gt;&lt;p&gt;  \&quot;Sometimes it&#039;s strange to wake up and realise the position in which we now held \u2014 we have become a national institution!\&quot; he said of the group&#039;s success.&lt;\/p&gt;&lt;p&gt;  \&quot;And nothing brings this home more than this incredible tribute from Royal Mail.\&quot;&lt;\/p&gt;&lt;p&gt;  The Royal Mail previously honoured the Beatles in 2007 and Pink Floyd in 2016.&lt;\/p&gt;&lt;p&gt;  May and Taylor continue to perform as Queen + Adam Lambert with singer Adam Lambert.&lt;\/p&gt;&lt;p&gt;  The group recently released a new version of Queen&#039;s song We Are The Champions, titled You Are The Champions to raise funds for Covid-19 relief.&lt;\/p&gt;&lt;p&gt;\u00a9 New Straits Times Press (M) Bhd&lt;\/p&gt;&quot;,&quot;body_with_inline&quot;:&quot;&lt;p&gt;KUALA LUMPUR: Iconic British rock band Queen, best known for its hits as Bohemian Rhapsody and We Will Rock You, is appearing on a special set of postage stamps in the United Kingdom.&lt;\/p&gt;\n&lt;p&gt;  American news portal UPI reported yesterday that Britain&#039;s Royal Mail unveiled a series of stamps on Tuesday featuring Queen&#039;s Brian May, Roger Taylor, the late Freddie Mercury and John Deacon. Mercury died at 45 in 1991.&lt;\/p&gt;\n&lt;p&gt;  \&quot;With their truly original, theatrical sound and effortless ability to mix musical styles, Queen is rock royalty. We pay tribute to one of the most loved bands of all time with these stunning stamps,\&quot; said Royal Mail&#039;s Philip Parker.&lt;\/p&gt;\n&lt;p&gt;  The Royal Mail will release the 13-stamp set on July 9, with pre-orders available beginning today.&lt;\/p&gt;\n&lt;p&gt;  The series features eight of Queen&#039;s album covers, including Queen II and News Of The World, a classic photo of the band and four shots from live shows.&lt;\/p&gt;\n&lt;p&gt;  \&quot;It&#039;s hard to put into words what I feel when looking at these beautiful stamps,\&quot; said Queen guitarist May.&lt;\/p&gt;\n&lt;p&gt;  \&quot;Since we four precocious boys started out on our quest 50 years ago, our lives have been devoted to making our impossible dream come true.&lt;\/p&gt;\n&lt;p&gt;  \&quot;Sometimes it&#039;s strange to wake up and realise the position in which we now held \u2014 we have become a national institution!\&quot; he said of the group&#039;s success.&lt;\/p&gt;\n&lt;p&gt;  \&quot;And nothing brings this home more than this incredible tribute from Royal Mail.\&quot;&lt;\/p&gt;\n&lt;p&gt;  The Royal Mail previously honoured the Beatles in 2007 and Pink Floyd in 2016.&lt;\/p&gt;\n&lt;p&gt;  May and Taylor continue to perform as Queen + Adam Lambert with singer Adam Lambert.&lt;\/p&gt;\n&lt;p&gt;  The group recently released a new version of Queen&#039;s song We Are The Champions, titled You Are The Champions to raise funds for Covid-19 relief.&lt;\/p&gt;\n&quot;,&quot;word_count&quot;:283}"></article-component>

<div id='div-gpt-ad-1463538766750-0' style='height:200px;margin:0 auto; width:400px;'>
<script type='application/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463538766750-0'); });
</script>
</div>
<article-related :nid="603350" class="mb-3"></article-related>
<div class="OUTBRAIN" data-src="https://www.nst.com.my/lifestyle/groove/2020/06/603350/showbiz-rock-band-queen-immortalised-british-postage-stamps" data-widget-id="GS_1"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
<div class="col-12 col-md-5 col-lg-4 sidebar">
<div id="div-gpt-ad-1397706555683-0" class="mx-auto my-3 text-center">
<script type="application/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1397706555683-0"); });</script>
</div>
<most-popular title="Most Popular"></most-popular>
<trending-block count="6"></trending-block>
<says-block></says-block>

<div id="div-gpt-ad-1497838820026-0" class="ad-unit">
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1497838820026-0'); });</script>
</div>
<div id='div-gpt-ad-1397706611337-0' style='width:300px; height:auto; margin:0 auto;'>
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1397706611337-0'); });</script>
</div>
</div>
</div>
</div>
</main>
<div id='div-gpt-ad-1397706490709-0' style='width:728px; height:90px; margin:0 auto 20px;'>
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1397706490709-0'); });</script>
</div>
<div id="bottom" class="py-4">
<div class="container-fluid px-5">
<div class="row">
<div class="col-12 col-lg-3 pr-4 mb-4 mb-lg-0 text-center text-lg-left">
<img src="https://assets.nst.com.my/assets/footer-logo.png?id=ece9a04a00702b02644c" srcset="https://assets.nst.com.my/assets/footer-logo.png?id=ece9a04a00702b02644c 1x, https://assets.nst.com.my/assets/footer-logo@2x.png?id=35776faa6e0e69b2db41 2x" class="img-fluid" />
<div class="d-block mt-3">
<div class="b-title" style="font-size:11px; text-transform:uppercase;">Get Mobile App</div>
<div class="d-flex align-items-center justify-content-center justify-content-lg-start">
<div class="b-logo mr-1"><img src="https://assets.nst.com.my/assets/nst-mobile.png?id=64a98fdbb64cccd8b36a" srcset="https://assets.nst.com.my/assets/nst-mobile.png?id=64a98fdbb64cccd8b36a 1x, https://assets.nst.com.my/assets/nst-mobile@2x.png?id=49247ac874f8f9f7423b 2x"></div>
<div class="d-flex flex-column">
<a class="mb-1" href="https://apps.apple.com/my/app/new-straits-times/id1033411389" target="_blank"><img src="https://assets.nst.com.my/assets/icon-ios.png?id=665d27c9e319c53c91c4" srcset="https://assets.nst.com.my/assets/icon-ios.png?id=665d27c9e319c53c91c4 1x, https://assets.nst.com.my/assets/icon-ios@2x.png?id=1ad24fa94574c0c8291e 2x" class="img-responsive"></a>
<a class="mb-1" href="https://play.google.com/store/apps/details?id=com.nstp.nst" target="_blank"><img src="https://assets.nst.com.my/assets/icon-android.png?id=0dba54f322386f13020e" srcset="https://assets.nst.com.my/assets/icon-android.png?id=0dba54f322386f13020e 1x, https://assets.nst.com.my/assets/icon-android@2x.png?id=c907fb74f10efa90468a 2x" class="img-responsive"></a>
<a href="https://appgallery5.huawei.com/#/app/C101980395" target="_blank"><img src="https://assets.nst.com.my/assets/icon-appgallery.png?id=c7f3a028a23d80d2d8e8" srcset="https://assets.nst.com.my/assets/icon-appgallery.png?id=c7f3a028a23d80d2d8e8 1x, https://assets.nst.com.my/assets/icon-appgallery@2x.png?id=b5703970b28a4f8180db 2x" class="img-responsive"></a>
</div>
</div>
</div>
</div>
<div class="col-12 col-lg">
<div class="bottom-menu d-flex justify-content-sm-between text-center text-lg-left flex-column flex-sm-row">
<div class="mb-4 mb-sm-0">
<a href="/news" class="link-header d-block">News</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/news/crime-courts">Crime & Courts</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/news/exclusive">Exclusive</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/news/government-public-policy">Govt / Public Policy</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/news/nation">Nation</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/news/politics">Politics</a>
</li>
</ul>
</div>
 <div class="mb-4 mb-sm-0">
<a href="/business" class="link-header d-block">Business</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/business">Business Times</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/property">Property</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/cbt">Cars Bikes Trucks</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/lifestyle" class="link-header d-block">Life & Times</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/lifestyle/sunday-vibes">Sunday Vibes</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/lifestyle/bots">Bots</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/lifestyle/heal">Heal</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/lifestyle/flair">Flair</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/lifestyle/jom">Jom!</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/lifestyle/groove">Groove</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/sports" class="link-header d-block">Sports</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/sports/football">Football</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/badminton">Badminton</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/tennis">Tennis</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/cycling">Cycling</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/golf">Golf</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/mma">MMA</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/motor-sports">MotorSport</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/cricket">Cricket</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/sports/others">Others</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/World" class="link-header d-block">World</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/world">World</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/world/region">Region</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/opinion" class="link-header d-block">Opinion</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/opinion/columnists">Columnists</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/opinion/letters">Letters</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/opinion/leaders">Leader</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/photos" class="link-header d-block">Gallery</a>
<ul class="nav flex-column">
<li class="nav-item">
<a class="nav-link" href="/photos">Photos</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/infographics">Infographics</a>
</li>
</ul>
</div>
<div class="mb-4 mb-sm-0">
<a href="/videos" class="link-header d-block">NSTTV</a>
<a href="/education" class="link-header d-block">Education</a>
<a href="http://vouchers.nst.com.my/" class="link-header d-block" target="_blank">Voucher</a>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer" class="py-3">
<div class="container d-flex align-items-center text-center text-lg-left flex-column flex-lg-row">
<div class="copyright mb-4 mb-sm-0">
2020 &copy; New Straits Times, New Straits Times Press (M) Bhd. A part of Media Prima Group.
</div>
<div class="footer-menu ml-lg-auto">
<ul class="nav justify-content-center justify-content-lg-start">
<li><a href="http://digital.nstp.com.my/nst/includes/shop/list_products.jsp?testata=nstnews&id=nstnews&utm_source=subscription&utm_medium=klik&utm_term=hm&utm_campaign=nstnews" target="_blank">Subscribe</a></li>
<li><a href="/disclaimer">Disclaimer</a></li>
<li><a href="/privacy">Personal Data Protection Act</a></li>
<li><a href="/contact">Contact Us</a></li>
</ul>
</div>
</div>
</footer>
</div>
<script src="https://assets.nst.com.my/assets/js/desktop/app.js?id=3ca74477408732730ba0"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5e2578aea74df413"></script>

<div id='div-gpt-ad-1565318969398-0'>
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1565318969398-0'); });</script>
</div>

<div id='div-gpt-ad-1535527649803-0' style='height:1px; width:1px;'></div>
<script type="application/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1535527649803-0'); });</script>

<div id='div-gpt-ad-1572338498636-0' style='width: 1px; height: 1px;'>
<script type="application/javascript">
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1572338498636-0'); });
  </script>
</div>

<div id='div-gpt-ad-1463538534546-0'>
<script type="application/javascript">
  googletag.cmd.push(function() {
    var fn_desktop_pageskin = "false";
    if (screen.width >= 1495) {
      fn_desktop_pageskin = "true";
    }
    googletag.pubads().setTargeting("inskin_desktop_yes", fn_desktop_pageskin);
    googletag.display('div-gpt-ad-1463538534546-0');
  });
  </script>
</div>
<div id="div-gpt-ad-1563439757140-0" class="ad-unit">
<script>googletag.cmd.push(function() { googletag.display("div-gpt-ad-1563439757140-0"); });</script>
</div>
</body>
</html>
